Status: Open
Status: Answered
Status: Closed
Status: Duplicate

Appworks Setup Issues

Posted Feb 03 by Ramesh Chalamalla.

I'm facing issues while setting up the Appworks Gateway installation. I have installed Appworks Gateway 16.3.1, JDK 1.8.144 and Tomcat 8.0.47. When i launch the browser using http://localhost:8080/gateway tomcat logs are throwing the exceptions below.
from gateway-otag log#

> ERROR services.impl.PersistenceServiceImpl - We were unable to create
> the database connection. No file defined.
> com.opentext.otag.exception.DBException: No file
> defined. at
> ~[classes/:?]at
> ~[classes/:?] at
> ~[classes/:?]

At the same time i can see from gateway log file the below error#

> 2018-02-03 16:19:42,6682018-02-03T16:19:42,668 [Thread-6] INFO
> service.impl.StatusBeanImpl - ==Attempting to jump starting Gateway
> services, this node may already be configured 2018-02-03
> 16:19:42,6682018-02-03T16:19:42,668 [Thread-6] ERROR
> service.impl.StatusBeanImpl - Jump start failed, the Gateway may not
> be setup yet com.opentext.otag.exception.OTAGException: We were unable
> to create the database connection. No file
> defined.No file defined.

Appreciate if some one helps out

4 Answers

BEST ANSWER: As chosen by the author.


Those logs entries are expected as the gateway database connection has not yet been setup , as you haven't got that far in the setup process.On startup the gateway looks for the file which it needs to decrypt the contents of to connect to its database if it can't find the file it assumes its a new install and will start the setup process.

Dont use localhost use the IP or FQDN of the host upon which you are running the Gateway Tomcat on when trying to access the gateway in a browser.

If you are unsure of the hostname the gateway has been given take a look in the Tomcat. Catalina log and early on in the startup process you should see the hostname Tomcat has advised the gateway of so use that

Hope that helps


BEST ANSWER: As chosen by the author.

Thanks Simon for your quick response, it worked with IP address.

BEST ANSWER: As chosen by the author.


No problem at all

I will close the question as answered if thats ok with you


BEST ANSWER: As chosen by the author.

Yes sure

 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.


Related categories

Your answer

To leave an answer, please sign in.